Foros de daboweb

HARDWARE Y SISTEMAS OPERATIVOS, GNU/Linux, Windows, Mac => GNU/Linux, Unix, *BSD and Free Software, Android => Mensaje iniciado por: gabriel_cax en 08 de Agosto de 2006, 08:01:44 am

Título: SuSE Linux 10.1 y router D-Link DSL504-T (SOLUCIONADO)
Publicado por: gabriel_cax en 08 de Agosto de 2006, 08:01:44 am
Buenas.

Pues tengo un problema un pelín subrealista con SuSE Linux y un router D-Link DSL-504T y éste es, que no puedo navegar por internet con mozilla firefox y sí con konkeror, cosa rarísima y lo que es peor, tampoco me deja actualizar el sistema operativo.

Se queda ahí, en una permanente espera hasta que da el aviso de que no puede conectarse con los servidores.

O sea, rarísimo todo, aunque estoy convencido de que debe ser alguna chorrada de la configuración del router. Por cierto, con windows y firefox si puedo navegar perféctamente y si hace las acualizaciones de windows. Lo comprobamos ayer mismo.

Si alguien me puede ayudar le quedaré etérnamente agradecido. Ando un pelín desesperado ya.

Gracias y un saludo a [email protected] |o|
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: goldfinger en 08 de Agosto de 2006, 08:19:53 am
Pues si que es raro, si puedes conectarte desde win y con konkeror no creo que sea el router.

Comprueba la configuracion de red del equipo por si hubiera algún problema y nos cuentas
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 08 de Agosto de 2006, 07:56:56 pm
El problema no es del router, lo tiene tu ordenador. ¿habrás tocado algo en la configuración proxy de firefox? Repásala.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 09 de Agosto de 2006, 07:59:03 am
Podría ser. Pero eso, en todo caso, me solucionaría la navegación con Firefox. Lo miraré. Pero... ¿la actualización on-line del sistema operativo?. ¿Donde se configura en SuSE Linux el acceso a internet para actualizaciones e instalaciones de software vía internet?. Igual es una tontería lo que estoy preguntando, pero es que ando un poco perdido.

De nuevo gracias.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: goldfinger en 09 de Agosto de 2006, 08:45:36 am
Citar
¿Donde se configura en SuSE Linux el acceso a internet para actualizaciones e instalaciones de software vía internet?

Pero la navegación con firefox se solucionó? Quiero decir, si no se ha solucionado, es un problema con la configuración de red, revísala

Si puedes navegar pero no te actualiza, habría que comprobar la configuración del gestor de actualizaciones, hace tiempo que no toco suse pero, supongo que podrás hacerlo desde yast.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 09 de Agosto de 2006, 09:09:53 am
No lo he probado todavía (lo de navegar). En realidad el problema no es mío sino de un amigo al que he convertido a Linux (si me he hecho apostol de Linux que pasa  :) ). Esta tarde quedaré con él a ver que tal.

Como siempre, gracias.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 09 de Agosto de 2006, 12:41:26 pm
Perdón, no había leido lo de que no podías actualizar el sistema operativo.
Pues como te dice goldfinger es un problema de configuración de red.
A ver si nos puedes dar algún dato mas,
un saludo
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Dabo en 09 de Agosto de 2006, 05:55:41 pm
Hola, a mi lo que me "mosquea" es que navegue con Konqueror y no con Firefox, hace años que no toco Suse pero no creo que pueda ser el firewall que por lo que sea haya cortado el paso de Firefox a la red.

Más bien creo que se puede tratar como dicen de un problema de la propia red pero claro, lo del Konqueror me despista y mucho.

Que haga algo como esto en la consola, escribe;

primero ver el estado de los dispositivos de red

ifconfig  , ahí debería ver la interfaz eth0 (normalmente el cable) y por ejemplo si va por wifi eth1 aunque esto puede cambiar, si no ve nada...mala cosa. Te deberia salir algo como esto

eth0      Link encap:Ethernet  HWaddr 00:01:02:03:04:05
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:264830 errors:0 dropped:0 overruns:0 frame:0
          TX packets:255396 errors:0 dropped:0 overruns:0 carrier:0
          collisions:348 txqueuelen:1000
          RX bytes:42375618 (40.4 MiB)  TX bytes:20306080 (19.3 MiB)
          Interrupt:11 Base address:0xd000

para reiniciar los dispositivos de red

service network restart

sino levanta el interfaz que lo haga de este modo;

ifconfig eth0 up


Después para ver si realmente está levantado

ifconfig de nuevo

Luego esto para ver si hay conectividad con la red local,

ping 192.168.1.2 (el último número, el 2 que lo sustituya por cualquier otro equipo de la red o que lo haga hacia el propio Router)

Después vemos la salida hacia fuera;

ping google.com


De todos modos si tiene activado DHCP  en el Router que lo reinicie por si acaso;

/etc/init.d/dhcpd restart

o sino que lo active para esa interfaz de red (eth0 suponiendo que sea esa vaya la del cable)

dhclient eth0


Yo uso Debian pero en principio debería ser igual

Saludos !
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 10 de Agosto de 2006, 08:08:44 am
Sí, bueno ayer, me llevé mi portatil a casa de mi amigo y bueno, vimos que pasaba lo mismo, que podía navegar con konqueror pero no con firefox y que además el sistema operativo no actualiza. Todo esto en mi portatil. Es decir no es de la configuración de red que tenemos en cada uno de nuestros ordenadores sino del router.

¿Y por qué digo esto?. Porque hicimos la prueba de intentar abrir puertos del router usando la web del propio router. Siguiendo todos los pasos, no conseguíamos abrir puertos. No guarda los cambios, se queda ahí colgadillo y no los abre.

Decidimos entonces actualizar el firmware del router. Pero fue peor el remedio que la enfermedad: ya no conseguíamos ni acceder al router via web. En fin, desastroso. Le he recomendado a mi amigo que pida otro router a su ISP (ya.com). Porque el mío que es un speedtouch va de lujo y sin problema ninguno. De hecho cuando volví a casa y conecté mi portatil fue todo bien y a la primera.

En fin. Supongo que lo que haré sera reiniciar el router con el firmware anterior a la actualización y volver a intentar la conexión. Y, por supuesto, dar mucho el coñazo a ya.com para que le proporcionen otro router que funcione bien, ya que pienso que es un defecto hardware del propio router.

Saludos y gracias por las informaciones. :smoke:
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: goldfinger en 10 de Agosto de 2006, 08:33:50 am
 |o| Que extraño es lo que te ocurre..

Cuando actualizas el firmware del router es posible que después solo permita el acceso por el puerto serie, o con suerte por telnet.
Por curiosidad, que router es?
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Liamngls en 10 de Agosto de 2006, 08:59:03 am
Pues tengo un problema un pelín subrealista con SuSE Linux y un router D-Link DSL-504T

Debe ser ese  :ciego:
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: goldfinger en 10 de Agosto de 2006, 10:14:15 am
oups   :-x  este calor...   :ciego: :mrgreen:
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 10 de Agosto de 2006, 11:33:30 am
No recomiendo actualizar el firmware si no es realmente necesario, es una operación que muchas veces acaba con la "muerte" del aparato.
La verdad es que es un tema muy extraño, me gustaría tenerlo a mano, estos misterios me encantan, te hacen aprender un huevo.
Supongo que habreis probado a reiniciar el router.
¿Has hecho ping al exterior? ¿primero a "número" (por ejemplo "ping -c1 80.58.34.33") y después a dirección ("ping -c1 www.google.es", a ver que es lo que te da? y ¿al router?
¿Habeis probado a cambiar las DNS (usar otras o cambiarlas de orden)? Prueba tambien a meterselas al ordenador, que sea el el que directamente pregunte a las DNS, no al router.(las puedes meter en /etc/network/interfaces o en /etc/resolv.conf)
Si pudieras echar un vistazo tanto a los logs del router como a los del sistema("dmesg" "cat /var/log/syslog") , pues estaba bien.
un saludo!!!
 
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Aj en 10 de Agosto de 2006, 11:42:28 am
Vaya... he seguido el tema en la sombra....

Pero vamos, yo he tenido ese mismo router una temporada (como pitaba el jodido) y no me ha pasado nada de eso.... navegaba correctamente y tal, funcionaba todo ok. Lo raro es que con konqueror dejase y con el resto no.

Y hombre empanada, tampoco hay que ser tan drastico, hacer un upgrade al firmware no se puede hacer a la ligera, pero en ocasiones viene muy bien (como en los linksys  :haha: :haha: :haha:)
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Dabo en 10 de Agosto de 2006, 05:28:11 pm
yo me voy a quedar con una curiosidad dentro que no se  :ciego: , más vale que nos tengas informados  :-d
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 10 de Agosto de 2006, 10:41:02 pm
yo me voy a quedar con una curiosidad dentro que no se  :ciego: , más vale que nos tengas informados  :-d
Yo tambien!!!! Me corroe la curiosidad de hecho.  :blind:
Aj, bueno, quizás es un pelín radical...pero es que mucha gente se pone a actualizar firmware como quien actualiza windows, y como falle la actualización (muy frecuente, sobre todo en routers que no sean de calidad), la cagaste. La gente no se lee bien las instrucciones y/o no sabe lo que se trae entre manos y muchas acaban mal.
Desde luego un Linksys(marca para el gran público de Cisco) es MUY dificil que se cuelgue durante una actualización.
D-link tambien es muy buena marca, pero no es Linksys y si no se está seguro de lo que se hace...
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Dabo en 10 de Agosto de 2006, 11:55:50 pm
ja ja empanada vamos a hacerle una visita y salir de dudas -;)
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 21 de Agosto de 2006, 08:52:00 am
Buenas otra vez.

Lo primero disculparme por haber tenido el hilo tan descuidado estos días, pero es que he estado de vacaciones y bueno, cuando se desconecta, se desconecta.

Dicho esto os informo de como van las cosas.

Efectívamente al actualizar el firmware del router, éste, se fue al carajo. Muerte cerebral irreparable.

Pero por fin, nos han mandado otro router, un D-Link DSL 524-T. Éste por lo menos se deja manipular, es decir, podemos abrir puertos y configurarlo como nos venga en gana. En el anterior no podíamos y eso era lo que me hacía sospechar que todas nuestras desdichas venían por mal funcionamiento del router.

Pero no. Sigo teniendo el mismo problema. Es decir, con Konqueror puedo navegar perféctamente, pero con Firefox ni de coña y sigue sin actualizar el sistema operativo.

En windows le tuve que poner las DNS fijas para que funcionara, pero en SuSE Linux no se como hacerlo. El caso es que en windows funciona perféctamente y con SuSE no. Si me pudierais informar como poner las DNS fijas os lo agradecería.

Por cierto, para asegurarme, volví a instalar SuSE Linux 10.1 como instalación nueva, pero sigue sin actualizar el sistema y sin poder navegar con Firefox, aunque como digo, con Konqueror si puedo.

Otra cosa curiosa, durante la instalación nueva si que pudo bajarse la ultima versión de las notas de la instalación. Pero como digo, una vez instalado, no pude hacer las actualizaciones. El error que me dio es más o menos que había pasado demasiado tiempo esperando respuesta del servidor (el mismo problema que al intentar navegar con Firefox).

En fin, un lío bastante subrealista.

Y no es el router, aunque si puede que sea algún tipo de incompatiblidad.

Saludos y gracias por vuestra ayuda.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Aj en 21 de Agosto de 2006, 09:17:34 am
Vamo a ver....

Por lo que leo (así rapidamente... no tengo mucho tiempo ahora...) el problema son las DNS.

Edita el fichero /etc/resolv.conf y pon lo siguiente

nameserver xx.xx.xx.xx

La Ip pon las de tu ISP o las que te venga en gana (yo tengo un popurri de DNS).  Tienes que poner una linea por direccion Ip de dns que tengas....  Te pongo alguna de ejemplo

nameserver 80.58.0.97
nameserver 87.216.1.65
nameserver 87.216.1.66
nameserver 194.179.1.101
nameserver 62.14.4.64
nameserver 62.81.0.1
nameserver 80.58.61.250
nameserver 80.58.61.254
nameserver 62.37.225.58
nameserver 213.172.33.35

Ya nos contaras....
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 21 de Agosto de 2006, 09:47:55 am
De acuerdo, probaré esta tarde, o cuando pueda mi colega (el ordenador es suyo) lo de las DNS.

Gracias.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: Aj en 21 de Agosto de 2006, 10:12:04 am
De acuerdo, probaré esta tarde, o cuando pueda mi colega (el ordenador es suyo) lo de las DNS.

Gracias.

Creo que además habría que decirle que no cogiese las dns automaticamente..... eso cuando venga algun experto en SUSE que te indique  :haha: :haha:
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 21 de Agosto de 2006, 10:15:26 am
Mete las dns's en /etc/resolv.conf como te ha dicho Aj.No uses dhcp, usa ip local fija. Yo uso la dns 80.58.34.33 . A veces 194.224.52.35 o 194.224.52.36.

Vete haciendo ping consucutivamente de la siguiente manera:

#ping -c1 router             
router=ip del router (supongo 192.168.1.1 o 192.168.0.1 o....). Esto te da la conectividad con el router, es decir, si obtienes respuestas es que Suse y el router se ven

Seguimos:
#ping -c1 80.58.34.33
esta ip no es mas que un ordenador en internet
Si obtienes respuesta es que estas conectado a Internet, otra cosa es q el servicio DNS (por culpa del servidor, o bien por fallo en tu Suse), funcione mal.
 
Seguimos:
#ping -c1 www.google.es

Repite mas ping a otros dominios(ya.com o lo que se te ocurra), y lee los resultados, a ver si son estables. Me explico con lo de estables: no debe de fallar en ninguno de los pings, ni retrasarse en exceso, compara los tiempos de respuesta, si alguno de ellos es exageradamente grande el problema está con el servicio DNS, si cambias las dns y aun así persiste el problema, quizás sea un problema del servicio local.
un saludo
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: gabriel_cax en 21 de Agosto de 2006, 11:16:05 am
No, si los ping si los hace bien. Eso lo probé con google y funciona bien.

Lo que no hace es navegar con Firefox y tampoco actualiza el sistema. Da el error ese de que ha esperado demasiado tiempo la respuesta del servidor. En fin, es todo muy raro.

Por cierto, ¿como hago para evitar el dhcp?.
Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: empanada en 21 de Agosto de 2006, 12:53:21 pm
Para pasar a ip estática:
probablemente en tu /etc/network/interfaces tengas algo como esto:
Código: [Seleccionar]
auto eth0
iface eth0 inet dhcp


Pues lo cambias por algo como esto:
Código: [Seleccionar]
auto eth0
iface eth0 inet static
        address 192.168.1.2
        netmask 255.255.255.0
        gateway 192.168.1.1

un saludo
Título: Solucionado
Publicado por: gabriel_cax en 30 de Agosto de 2006, 09:23:20 am
Bueno, pues como explicar la dicha que me invade.

Por fin, lo hemos conseguido. Al final instalamos la versión 10.0 de SuSE Linux y pusimos las DNS fijas, así como la IP, la Puerta de enlace predeterminada y la máscara de subred, anulando el DHCP.

Ya va estupendo.

No me pregunteis por qué, pero en la versión 10.1 el ponerlo todo fijo (DNS, etc.), no funcionaba. Pero con la 10.0, sí. Supongo que la gente de SuSE se habrá olvidado de meter algo en la nueva versión.

El caso es que ya funciona y estoy muy contento.

Gracias a [email protected] [email protected] que me habeis ayudado con este estúpido problema.

Saludos.  :smoke:

Título: Re: SuSE Linux 10.1 y router D-Link DSL504-T
Publicado por: destroyer en 30 de Agosto de 2006, 10:49:30 am

Gracias por comentarlo amigo. Damos el tema por solucionado.

Un saludo