Autor Tema: No me funciona regla iptables para redireccionar puertos!  (Leído 2485 veces)

Desconectado falc0nX

  • Newbie
  • *
  • Mensajes: 1
  • www.daboweb.com
No me funciona regla iptables para redireccionar puertos!
« en: 29 de Septiembre de 2015, 05:21:31 am »
buen dia actual mente tenia montado un servidor en ubuntu 9.10 de hace un aproximado de 3 años funcionando bien pero lo tenia en una laptop que se me daño por unas sobrecargas de corriente. entonces me vi obligado a configurar de nuevo un servidor cache con squid pero necesito usarlo de forma transparente pero he utilizado las mismas reglas que tenia en el anterior y no se que estoy haciendo mal pero no me funciona dejo todo por detallado si alguien me pudiera ayudar se lo agradezco.

Dejo todos los pasos para que vean como fue mi procedimiento esta configurado el squid solo con la eth0.

PASO 1.- CONFIGURACION DE LOS POOLS



PASO 2.- DANDOLE ACCESO A LAS REGLAS POOLS POR HTTP





PASO 3.-  CONFIGURACION PUERTO TRANSPARENTE PARA QUE FUNCIONEN LAS IPTABLES



PASO 4.- ASIGNANDO MEMORIA RAM A LA CACHE PARA QUE SEA MAS RAPIDO




PASO 5.-  CREANDO EL DIRECTORIO CON EL TOTAL A ALMACENAR EN CACHE




PASO 6.- COLOCANDOLE MGR




CON ESTO YA FUNCIONA EL SQUID POR EL PUERTO 3128!! (Pero se supone que ahi que cambiar el puerto desde el explorador y para que funcione sin tocar nada del explorador solo agregaba lo siguiente)



en el directorio /etc/rc.local

y listo cuando se reiniciaba volvia a activarse el script de iptables pero esta vez no me funciona!


Despues de toda esta informacion donde ya esta armado el squid y funcionando en modo normal agrego este script que me funciono hace 3 años seria lo siguiente.

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

con esto nunca tuve problemas con el transparente me funciono a la primera hace 3 años pero esta vez volvi a instalar el ubuntu 9.10 solo que aclaro no podia descargar el squid y cambie los sources a los OLD y de ahi le di update y luego upgrade con esto me dejo bajar el squid e instalar el webmin y todo pero los iptables no me funcionan ni activando en webmin la opcion de redireccionamiento de puertos y en mi servidor anterior solo deje el script de iptables en rc.local para que si se reiniciaba que volviera a cargar la regla de redireccionamiento.


dejo tambien como aparece en webmin

1.- opcion de redireccionamiento desde webmin



2.- configurando el firewall de linux



3.- configuracion de redireccionamiento desde modo webmin y el linux



Gracias si alguien sipiera alguna mejor forma de hacerlo y me pudiera pasar la imagen del VMWARE para crear una maquina virtual asi poder probarlo se los agradeceria o si supieran como hacer funcionar mi viejo servidor que me funciono al 100 hasta ahora please gracias!

y pues el puerto ya esta tambien en webmin




 

Aviso Legal | Política de Privacidad | Política de Cookies

el contenido de la web se rige bajo licencia
Creative Commons License