Autor Tema: Error en worpress (SOLUCIONADO)  (Leído 5900 veces)

Desconectado Vimbo

  • Newbie
  • *
  • Mensajes: 3
  • www.daboweb.com
    • VimboBlog
Error en worpress (SOLUCIONADO)
« en: 27 de Enero de 2014, 04:54:32 pm »
Hola, acabo de instalar worpress  en debian la versión 3.6.1. Y lo tengo subido a mi servidor mediante ftp, con todos los datos, entro en wordpress, con mi nuevo blog y me aparecen los siguientes mensajes de error:

Warning: constant(): Couldn't find constant WP_CORE_UPDATE in /home/u665789731/public_html/wp-admin/includes/update.php on line 33

Warning: require_once(/home/u665789731/public_html/wp-includes/class-phpmailer.php): failed to open stream: No such file or directory in /home/u665789731/public_html/wp-includes/pluggable.php on line 225

Fatal error: require_once(): Failed opening required '/home/u665789731/public_html/wp-includes/class-phpmailer.php' (include_path='.:/usr/lib/php') in /home/u665789731/public_html/wp-includes/pluggable.php on line 225

A que se deben  y como solucionarlo, gracias...  :verysad:
Sólo sé que no sé nada

Desconectado Liamngls

  • Administrator
  • ******
  • Mensajes: 15674
    • Manuales-e
Re:Error en worpress
« Respuesta #1 en: 27 de Enero de 2014, 08:27:42 pm »
¿En que momento te sale eso exactamente, no se completa la instalación?

Por cierto, que vas un poco anticuado con la versión, la última es la 3.8.1 y lo mismo con esa no te da problemas ¿estás siguiendo algún tutorial para la instalación, el alojamiento cumple los requisitos mínimos?

Por otro lado entiendo por tu mensaje que instalas ¿en debian? y ¿luego lo subes al servidor? No me queda muy claro, el principio es subir los archivos al alojamiento y realizar la instalación ahí a través de un navegador.

Desconectado Vimbo

  • Newbie
  • *
  • Mensajes: 3
  • www.daboweb.com
    • VimboBlog
Re:Error en worpress
« Respuesta #2 en: 28 de Enero de 2014, 02:43:31 pm »
Yo escribí :
Hola, acabo de instalar worpress  en debian la versión 3.6.1. Y lo tengo subido a mi servidor mediante ftp, con todos los datos, entro en wordpress, con mi nuevo blog y me aparecen los siguientes mensajes de error:

Warning: constant(): Couldn't find constant WP_CORE_UPDATE in /home/u665789731/public_html/wp-admin/includes/update.php on line 33

Warning: require_once(/home/u665789731/public_html/wp-includes/class-phpmailer.php): failed to open stream: No such file or directory in /home/u665789731/public_html/wp-includes/pluggable.php on line 225

Fatal error: require_once(): Failed opening required '/home/u665789731/public_html/wp-includes/class-phpmailer.php' (include_path='.:/usr/lib/php') in /home/u665789731/public_html/wp-includes/pluggable.php on line 225

He realizado la instalación de wordpress en Debian y luego lo he subido mediante FTP a mi servidor he hecho la instalación correctamente, ya tengo mi blog pero en la parte superior  de la configuración  de mi blog aparece esos errores, supongo que abra habido un fallo en esos archivos y no se abran cargado bien en el servidor o falta algun parámetro , pues también me cuesta mucho instalar plugin , tarda en cargase y el de Latch no consigo sincronizarlo con mi móvil en Latch Token. Va todo muy lento..
Sólo sé que no sé nada

Desconectado Liamngls

  • Administrator
  • ******
  • Mensajes: 15674
    • Manuales-e
Re:Error en worpress
« Respuesta #3 en: 28 de Enero de 2014, 06:14:28 pm »
A mi me parecería mucho más práctico que lo instalases como corresponde que es subiendo los archivos al servidor y ejecutando ahí el instalador, el problema de instalar en A y mover a B es que algunas rutas se corrompen o no corresponden con B porque apuntan a A.

De todos modos con un editor de texto puedes comprobar los archivos a los que apunta el error, mirar al línea que se indica y a partir de ahí será más fácil encontrar la solución, por ejemplo:

Fatal error: require_once(): Failed opening required '/home/u665789731/public_html/wp-includes/class-phpmailer.php' (include_path='.:/usr/lib/php') in /home/u665789731/public_html/wp-includes/pluggable.php on line 225

Según eso tendrías que abrir pluggable.php en /wp-includes/ y en la línea 225 añadir include_path='.:/usr/lib/php'

Desconectado Vimbo

  • Newbie
  • *
  • Mensajes: 3
  • www.daboweb.com
    • VimboBlog
Re:Error en worpress
« Respuesta #4 en: 29 de Enero de 2014, 02:47:41 pm »
Holaa, ya esta solucionado, añadí lo que me pedía, pero además he actualizado el wordpress a la  ultima   versión, 3.8.1,  y ahora ya no me da errores , y va mucho mas fluido, aunque eso depende también mucho de mi hostin,  lo barato no puedo pedir mucho,  :).
Gracias Liamngls por ir contestando mis fallos de novato ;)
Worpress es el primer CMS que uso, ahora a asegurarlo con los plugin que recomienda Dabo.
Saludos
Sólo sé que no sé nada

Desconectado Liamngls

  • Administrator
  • ******
  • Mensajes: 15674
    • Manuales-e
Re:Error en worpress (SOLUCIONADO)
« Respuesta #5 en: 29 de Enero de 2014, 07:22:48 pm »
Me alegro, un saludo  :)

Desconectado Dabo

  • Administrator
  • *
  • Mensajes: 15276
    • https://www.daboblog.com
Re:Error en worpress (SOLUCIONADO)
« Respuesta #6 en: 26 de Febrero de 2014, 07:55:29 pm »
Muyyy tarde pero entro (lo tenía como leído) Gracias Liam por la ayuda y bienvenido al foro, recuerda que he publicado un webcast sobre seguridad en WordPress en mi blog http://www.daboblog.com/2014/02/21/webcast-en-escuelait-con-oreixa-sobre-seguridad-y-wordpress/

Saludos !
Hacking, computing, are in my blood, are a part of me, a part of my life...Debian GNU/Linux rules.

Twitter; https://twitter.com/daboblog
Instagram: @daboblog


www.daboblog.com | www.debianhackers.net | www.caborian.com | www.apachectl.com | www.davidhernandez

 

Aviso Legal | Política de Privacidad | Política de Cookies

el contenido de la web se rige bajo licencia
Creative Commons License