Autor Tema: Unas dudas sobre Knoppix 3.7 (SOLUCIONADO)  (Leído 6126 veces)

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Unas dudas sobre Knoppix 3.7 (SOLUCIONADO)
« en: 20 de Junio de 2006, 03:44:03 pm »
Buenas, soy nuevo y tengo unas dudillas.

A ver, estoy inmerso en un proyecto fin de ciclo, y lo tengo que entregar mañana :(. Se trata de generar un LIVE-CD Knoppix ( o cualquier Debian, pero yo elijo esta).

Mis problemas comienzan cuando intento actualizar los paquetes del sisetma con apt-get update, queme lee la lista de paquetes y todo, pero cuando va por el 99% me peta y me dice algo sobre paquetes no instalados o rotos... que puedo hacer???

Me vendría bien un fichero /etc/apt/sources.list que funcione al igual que un /var/lib/apt/lists, porque de buscar y añadir nuevos repositorios creo que al menos el sources.list me lo he cargado...

También agradecería cualquier manual/explicación de alguien que ya lo hubiera realizado. Y sin ánimos de meter prsa, me urge muchísimo!

Gracias de antemano! Que quien me recomendo esta peige hablaba maravillas...

Desconectado Liamngls

  • Administrator
  • ******
  • Mensajes: 15587
    • Manuales-e
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #1 en: 20 de Junio de 2006, 10:05:29 pm »
Mientras te dan una respuesta en condiciones puedes ver esto: http://www.badopi.org/cdlive_metadistros

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #2 en: 21 de Junio de 2006, 12:00:03 am »
Gracias Liamngls, mirare mientras...

Desconectado Dabo

  • Administrator
  • ******
  • Mensajes: 15151
    • http://www.daboblog.com
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #3 en: 21 de Junio de 2006, 11:32:11 am »
Hola amigo que versión tienes instalada exactamente??? quizás con "comentar" alguna línea del sources sea suficiente

¿cual es el mensaje que te da? o el paquete que "casca"

Estoy sin tiempo ahora pero haz esto

Instala  apt-spy:

apt-get install apt-spy

Luego ejécutalo y te generará un sources.list más potente al momento, yo en Debian tengo los míos pero vaya, esto lo he hecho con alguna live para cosas rápidas y va bien, luego ya lo adaptas a tus gustos


(más info en http://packages.debian.org/stable/admin/apt-spy)

Saludos -;)

Hacking, computing, are in my blood, are a part of me, a part of my life...Debian GNU/Linux rules.

Twitter; @daboblog --> http://twitter.com/daboblog

www.daboblog.com | www.debianhackers.net | www.caborian.com | www.apachectl.com | www.hackeando.com | www.davidhernandez.es

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #4 en: 21 de Junio de 2006, 05:05:27 pm »
Pues muchas gracias Dabo... pero el problema es tal que no me deja instalar ningún paquete... estoy probando a instalar de nuevo o migrar a otra distro... pienso que mis sources.list está loc desués de todo lo que he modificado...

Trabajo con knoppix 3.7.

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #5 en: 21 de Junio de 2006, 05:52:53 pm »
Perdonadme que abra otro post y no edite el anterior, pero quiero reportaros el error que me lanza knoppix cada vez que hago cualquier cosa con apt-get:

Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.


Si alguien me dijera el porque de este error y como se puede solucionar... se lo agradezco!

Desconectado goldfinger

  • Pro Member
  • ****
  • Mensajes: 606
  • Where there's a will there's a way
    • Das Reboot
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #6 en: 23 de Junio de 2006, 11:46:41 am »
Citar
Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.

¿Antes de eso te dice algo asi como "No se puede leer la lista de paquetes fuente xxxxxxx"?

Ese error se debe a que en tu sources.list hay alguna fuente obsoleta o incorrecta, la solución es la que te comenta Dabo, un archivo sources.list correcto que se corresponda con tu versión de knoppix
A proposito, knoppix ya va por la version 5, puedes probar a actualizarla

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #7 en: 23 de Junio de 2006, 10:08:08 pm »
El problema es que tengo que trabajar con una maquina virtual, y el equipo que tengo no es suficiente para ejecutar Knoppix 5.0... ni tan siquiera me carga la ejecución Live...

Desconectado empanada

  • Member
  • ***
  • Mensajes: 307
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #8 en: 25 de Junio de 2006, 12:02:01 pm »
Para ayudarte hace falta que postees el error CONCRETO.
No vale que nos digas "99% me peta y me dice algo sobre paquetes no instalados o rotos... ".
Postea la salida completa de apt-get update y del archivo /etc/apt/sources.list .
un saludo
No tengo miedo a morir, tengo miedo a no vivir.
Married to the Blues

Desconectado cherubino

  • Junior Member
  • **
  • Mensajes: 11
  • Quien quiere ventanas??
Re: Unas dudas sobre Knoppix 3.7
« Respuesta #9 en: 26 de Junio de 2006, 03:16:35 pm »
Bueno, lo he solucionado. Y creoque se merece que postee aquí la solución, puesto que me ha tenido mareado unos pocos de días.

Lo primero, agradecer a todos la ayuda!

Segundo, perdonad por no haber especificado mejor mi problema.

la solución:

Bueno, no se podía ejecutar apt-get update. La solución ha sido sencilla, no se pueden mezclar las versiones de stable, unstable o testing. En la lista de sources.list hay que dejar sólo de una versión y verificar las direcciones de que se queden disponibles por si acaso son obsoletas.

Al final me he quedado con tres direcciones, una de paquetes, otra de seguridad y otra más de paquetes actualizados de la versión stable.

He ejecutado apt-get upadate y ha ido a la perfección.

Lo dejo aquí por si alguien más está atascado.

Vulevo a agradeceros la ayuda chicos. :cool:

 

Aviso Legal | Política de Privacidad | Política de Cookies

el contenido de la web se rige bajo licencia
Creative Commons License